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Maya Fundamentals

This tutorial covers the basic layout of the Maya user interface and is intended to get you up to 
speed on Maya terminology and usage techniques.

In this tutorial:

n  Maya’s user interface components

n  Commonly used UI windows

n  Working in Maya’s camera viewport

n  Selecting and manipulating objects in Maya

n  Using Maya, Selection/Action vs. Tool based interactions
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Note: Before you start: This tutorial requires Maya scene files. If you haven’t installed the tutorial files go to the “Try 
Maya” section of the “Taste of Maya” CDROM to install.

Starting Maya: You can start Maya by double-clicking the Maya 2.5 Evaluation icon on the desktop or from Start 
→ Programs → Maya 2.5 Evaluation → Maya.

In Maya: Once the tutorial files have been installed you will need to set the current project in order to access the Maya 
scene files. To set the current project from within Maya select File → Project → Set... and Navigate to the directory 
where you installed the Maya scene files. Select the directory: Maya_tutorial_data and press OK.

Maya’s User Interface
Maya’s user interface is an amazing step forward in 3D graphics applications.

The first impression of Maya can be overwhelming. Maya has a huge range of capabilities and the UI (User Interface) 
will reflect this fact. When you understand how it all fits together and the common modes of functionality that run 
through Maya you will begin to see a pattern of usability. This pattern will enable you to explore any aspect of Maya 
on firm footing.

Sections inside this tutorial:

User Interface Components
The first section of this tutorial explores the main menu sets, windows and editors as well as components of Maya’s 
UI. 

Working with Objects and Cameras
The second section focuses on selecting and manipulating objects and cameras. Selection-action and tool based 
commands are discussed.

The Components of Maya’s User Interface
In the following tutorial steps you will be exploring Maya’s user interface or UI for short. 

1 Open Maya and a new scene file
n Start Maya

There are several ways to start Maya in Windows NT:

Double click the Maya program icon on the desktop.

Double click a Maya scene file from the explorer window.

Navigate from the start menu to Programs → Maya 2.5 Evaluation → Maya.
n A New Untitled scene file is opened automatically to provide a clean slate to start with.

For the process of getting familiar with the interface you will turn off all of the interface and one by one turn on 
each component.

2 Pop-up help
In Maya if you hold the mouse cursor over an icon in the user interface without moving it for a second a pop up 
help will show up with the name of the tool you are over.

3 Turn off all of the UI components
To turn off the UI components you will use the Options menu pull down.
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n Select the Options menu.
n Notice the two parallel bars at the top of the Options menu. If you LMB (Left Mouse Button) click on 

these bars you can detach the menu.

Detach the menu and drag it to the side out of the way.

This menu contains menus and UI components for customizing your UI and Maya preferences. It also 
contains two commands for quickly showing and hiding pieces of the UI:

Show Only Viewing Panes

Show All Panes
n Select Show Only Viewing Panes

This will turn off all of the elements that are listed above the command in the Options menu. The 
remaining elements are the camera viewport and the main menu.

4 Turn on individual UI components
n One by one select the UI elements that make up the list in the Options menu starting with the Status Line:

Status Line with Menu Set selector highlighted
n  Status Line: The Status Line contains many useful items, from left to right:

Main menu set selection

Selection locking

Selection masking

Hierarchy, Object, Components selection 

Pick Mask

Snapping: Grid, Curve, Point, and View Planes

Make selected object live

Input and Output operations lists

Toggle construction history on/off
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n  Shelf: The Shelf UI is comprised of two sections. The Mini-Bar section on the far left-hand side and the user-
defined “shelf” or tabbed command storage sections on the right hand side.

The mini bar contains commonly used tools including Selection, Move, Rotate, Scale, the Show 
Manipulator Tool, and the Currently Active Tool. The hotkeys for the items in the minibar from left to right 
are Q,W, E, R,T, Y.

Maya shelves are user defined. They can be created for several purposes but mainly are used to store 
commonly used organizations of commands. MEL (Maya Embedded Language) commands can be drag 
and dropped to the shelf to create a shelf button. To use the shelf icons you just need to click on one of the 
icons. For example if you click on the sphere icon in the shelf it will create a sphere.

n  Feedback Line: The Feedback Line communicates information back to the user. 

Depending on the manipulator or tool you are currently using, different information will be displayed in the 
Feedback Line. If you are rotating the camera for example, this rotation will be displayed in degrees on the 
Feedback Line.

n  Layer Bar: The Layer Bar contains layer creation and display buttons. 

Layers in Maya are a powerful method of organizing the display and collection of objects in your scene.
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For example, in preparation for compositing, you could put all your background objects on one layer. Your 
hero object could exist on its own layer while the foreground objects could make up yet another layer.

Layers are mutually exclusive, an object can only exist in one layer at a time. RMB clicking on the layer in 
the layer bar displays a menu allowing you to control the contents and display characteristics of its 
contents. Clicking the button at the far left of the Layer Bar creates a new layer.

n  Time Slider: The Time Slider contains the display and control of time playback, pause, rewind and some 
keyframing functions. 

From the Time Slider you can set the current frame as well as advance or retreat from the next keyframe 
on the selected object.

The LMB can be used to LMB drag and “scrub” the current time. Shift + LMB drag selects a region of 
time (highlighted in red) which can then be moved around the time slider, in effect moving keyframes 
around as a group.

Pressing RMB in the main region of the time slider displays a menu with a list of choices. For example you 
can Cut and Paste a selected region of keyframes back into the Time Slider or onto a different object 
entirely.

n  Range Slider: The Range Slider contains more UI used for controlling animation parameters. 

You can establish the range of animation frames in the scene and, by growing or shrinking the range slider, 
you can focus on certain regions of frames.
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On the right-hand side of the range slider are buttons to select the current Character, and toggle Auto 
Keyframing. The button on the far right-hand side displays the General Preferences Animation 
Preferences.

n  Command Line: MEL stands for Maya Embedded Language and is Maya’s built in scripting language. The 
Command Line contains a single line with which you can view and write MEL commands.

The left-hand portion of the command line is a text field where you can enter MEL commands. The right-
hand portion is a text field that displays the last printed line of MEL feedback visible in the Script Editor. 

The far right-hand side contains a button to raise the Script Editor window.

n  Help Line: The Help Line is very useful for new users as this line displays information about tools and 
procedures that the user is presented with as you work in Maya. 

As you drag your mouse over areas of the interface, information is displayed in the Help Line describing 
the item. When you are working with a command or tool the Help Line prompts you for the next expected 
action or present tips on using the current tool.

Popup Help is also available in Maya. Toggle Popup Help from the Help pull down menu.
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Channel Box

The last two items in the Options list are Channel Box and Attribute Editor. 

Since the Channel Box and Attribute Editor are similar in the information presented you will usually want 
one or the other displayed at one time. It is very handy to quickly change between these two windows. Also 
having them as part of the main Maya window is important to avoid cluttering the interface with floating 
windows.

n  Channel Box: The Channel Box is the work horse UI of Maya. This is where you will view and enter 
information into Maya. Maya is about nodes and the attributes on these nodes. The Channel Box is a simple 
lightweight UI for accessing and editing these attributes.

The top section of the Channel Box contains basic information about the selected object. These are the 
attributes that control where the object in the scene is.

Below this section are the nodes related to this object. The Shape nodes which carry information about an 
object beyond just its position, rotation and scale. For example the makeNurbCube shape node contains 
information about width, length to height ratio, and Patches in U and V directions. These attributes are 
editable and keyframable. 

Also listed in the Channel Box are the input and output nodes related to the selected object. By selecting 
these objects you can address these related objects.

Some Attribute fields in the Channel Box contain preset pulldown choice menus where applicable. LMB 
on an attribute field to see if it also contains a pulldown choice menu.
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Note: In the Channel Box and the Attribute Editor you can use your RMB when the cursor is over attributes and you will 
have access to a drop down menu specific to that attribute. RMB can be used in other areas as well. For example if you 
create a sphere and place the cursor over it and RMB a marking menu will show up specific to that object

Attribute Editor
n  Attribute Editor: The Attribute Editor is a more detailed version of the Channel Box. Whereas the Channel 

Box is an abbreviated list of keyable attributes, the Attribute Editor is a listing of all attributes on the selected 
node or object.

The Attribute Editor includes things like sliders, pulldown menus and drag and drop connections 
functionality.
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Objects in Maya have a top level node called a Transform node. This is the basic node used to control an 
objects position, rotation, and scale. These attributes are known as the Transform Attributes.

Objects in Maya have a secondary node known as a Shape node. The shape node contains information 
about an object’s surface history, render properties, and display quality.

Other nodes like texture and material nodes are best edited using the Attribute Editor in conjunction with 
the Hypershade/Visor windows.

The tabs located at the top of the Attribute Editor let you choose which node to edit. The items displayed in 
the body of the Attribute Editor are the attributes associated with that node.

n  Preferences: Maya’s preferences are broken up into several areas. General, UI, and Customizing:

General Preferences

General Preferences: The General Preferences is where the majority of Maya’s preference settings are be 
modified. These settings control general usability and functionality of commands. In the General Tab, for 
example, you can establish how big your Undo Queue is. TIP: For now set your Undo Queue to Infinite. 
In the Units Tab, for example you can set your frame rate and scene scale units. In the above image in the 
top right corner you will see to buttons with arrows pointing left and right. They are used to scroll through 
the tabs.
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UI Preferences: The UI Preferences allow you to set many of the options for how the UI will behave by 
default or on start up of Maya. For example in the Windows Tab, you should set the Open Attribute 
Editor to: In Main Maya Window so that the Attribute Editor will not be floating when you press the 
hotkey Ctrl - a.

Customize UI: The Customize UI menu contains separate editors for customizing your interaction with 
Maya:

Hotkeys...: The Hotkeys Editor is where you establish how commands are executed by short-cut key 
stroke combinations.

Colors...: The Colors Editor is where you set or change the way objects and interface components are 
colored.

Marking Menus...: The Marking Menus Editor is where you establish or customize the actions 
associated with Marking Menus. Marking Menus are a handy UI concept pioneered by Alias|Wavefront 
that display specialized menus at the location of your cursor.

To activate a marking menu you press a key while LMB dragging in the viewport. This action activates a 
system of menus that you can navigate. For example press the w key and then m. A marking meny will 
appear under the mouse which will allow you to change the move tool and the .

An example of marking menus exists by pressing the space bar to activate the hotbox. From in the hotbox 
you can LMB drag in different zones to initiate different related sets of marking menus.

Shelves...: The Shelves Editor is where you customize your shelves. From this editor you can create, 
reorganize and edit the contents of your shelves.

Panels...: The Panels Editor is also the Layout Editor. This editor lets you establish and edit the 
windows and configuration of windows (panels) that are displayed in Maya. 

Working efficiently in Maya will demand that you become comfortable with building layouts made of 
groups of panels. By building layouts for certain tasks like rendering, modeling and animating you can 
avoid having floating windows that get in your way. 

A common method of accessing layouts is by building shelf buttons that activate certain layouts. The 
Panels Editor is where you can build layouts and make shelf buttons to activate these layouts.

Animation | Modeling | Dynamics | Rendering
Maya has four basic modes of menu set organization. On the far right side of the Status Line is a pulldown menu for 
these menu sets. By selecting a menu set you are selecting the menus displayed in the main menu bar along the top of 
Maya. The four basic modes of menu set organization are:

n  Animation: The Animation menu set contains menus for: Setting keyframes, creating Set Driven Key 
relationships, Path animation and Constraints. Skinning and IK skeleton creation menus are also part of this 
menu set as are the menus supporting the Deformers.

n  Modeling: The Modeling menu set contains menus for creating curves and surfaces as well as Polygon 
creation and editing tools.

n  Dynamics: The Dynamics menu set contains menus for Particles, Rigid and Soft Body creation and editing 
tools. The Effects menu contains many pre-made dynamics effects tools and examples of what can be done 
with Maya’s dynamics tools.

n  Rendering: The Rendering menu set contains menus for creating lights and materials as well as texture 
application tools. The Paint Effects toolset menus are also located in this menu set. Rendering menus are also 
located here that allow you to do batch rendering which is how you render out a sequence of animation.
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Common Menus
The first seven menus from the left are common to all the menu sets: File | Edit | Modify | Create | Display | 
Window | Options. When the menuset is change, these seven menus do not change.

n  File: The File menu contains scene management menus and tools. Scene saving and import/export commands 
are found here as are the project management commands and menus.

n  Edit: The Edit menu contain the common commands that you perform on objects in the course of editing 
them. Duplicating, Deleting, Selecting, Parenting and Grouping are some of the commands presented here.

n  Modify: The Modify menu is a potpourri of commands and menus used to work with objects in a special 
manner. Enabling and Disabling nodes, centering an object’s pivot point, or enabling the Artisan tools are 
examples of some of the tools found here.

n  Create: The Create menu is where you go to create curves, primitive objects, cameras and locators and text 
objects.

n  Display: The Display menu contains commands that have to do with the display of objects and their 
components as well as Interface components like the grid and axes.

n  Window: The Window menu is how you access the windows and editors in Maya.

n  Options: The Options window as mentioned above is where you customize your Maya environment and set 
your preferences for how Maya will handle different circumstances.
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Hotbox

Hotbox
By pressing and holding down the space bar you invoke the Hotbox. The Hotbox is a centralized heads-up display 
for all the menus in Maya. The Hotbox contains marking menus and zones of interaction that can greatly increase your 
productivity.

The Hotbox can take a while to get used to but it can also unlock a great amount of screen space by removing the need 
for the main menus.

Using the Hotbox: 

Press and hold the spacebar to invoke the Hotbox.

The Hotbox is divided into quadrants. In the above image you can see a big X that radiates out from teh 
A|W in the centre. This defines the quadrants. To access a quadrant while holding the spacebar just move 
the cursor into the quadrant (but not over a menu) and press the LMB:

North: LMB select the layout views marking menu

South: LMB select the editor windows marking menu

East: LMB select the UI components marking menu

West: LMB select the object and component mask marking menu

The Hotbox Controls menu located in the West quadrant of the Hotbox contains menus for setting Hotbox 
properties. From this menu you can select how many menu sets are included in the Hotbox.

The Center A|W Hotbox button contains a marking menu for selecting camera views and the Hotbox 
style.

Windows and Editors in Maya
The following section explores the main windows and editors that you will use in Maya. 
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Outliner Window

Outliner
There are two main methods of looking at the contents of a Maya scene file: the Outliner and the Hypergraph. The 
Outliner displays the contents of your scene file in a listed format. The contents of the Outliner are presented as 
nested groups if the items under this group are part of a hierarchy. 

Using the Outliner:

Create a few objects by clicking on the sphere and cone icons in the shelf bar or open a scene file from one 
of the other tutorials (File →Open Scene...)

Open the Outliner from Window → Outliner

Select an object with LMB click. 

Re-order an object by MMB click drag (Line between other objects).
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Parent on object by MMB click drag (Lines Outline parent).

Expand/Collapse hierarchy by LMB on the + and - symbols.

Show Shape Nodes by RMB click select menu item.

Select multiple continuous objects in list, Shift LMB select top object then bottom object of list.

Select multiple non-continuous objects in list, Ctrl LMB select each object.

Hypergraph
The Hypergraph presents the contents of your scene in a different manner. The Hypergraph has two modes of 
operation for looking at the contents of your scene in two different ways.

Hypergraph Scene Hierarchy mode

The first mode is the Scene Hierarchy mode. This mode lets you see objects and their hierarchies much like the 
Outliner does but in a more freeform layout.

Using the Hypergraph: Scene Hierarchy mode

Open the Hypergraph from Window → Hypergraph

Select an object with LMB click.

Navigate around the window using the camera controls:

Zoom: alt + LMB +RMB

Pan: alt + MMB

Frame selected: press f

Frame all: press a

Re-order an object by LMB click drag (First select Options > Layout > Freeform Layout from the 
Hypergraph menus).

Parent an object by MMB click dragging one object on top of another object or group.

Expand/Collapse hierarchy by RMB select Expand or Collapse from menu.

Show Shape Nodes by selecting Options > Display > Shape Nodes in the Hypergraph Options menu.

Select multiple contiguous objects in list, LMB drag box around objects.

Select multiple non-contiguous objects in list, Shift LMB select each object.
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The second mode is the Upstream and Downstream Connections mode. This mode lets you see how the flow of 
information is moving from one node to another through connected attributes. This can be thought of as similar to a 
production line where each information travels between nodes, each with a specific task it performs on the 
information before passing it along to the next node in the stream.

Hypergraph Upstream and Downstream mode

Using the Hypergraph: Upstream and Downstream Connections

Enable the Upstream Downstream mode by pressing the Upstream Downstream button or select 
Graph > Up and Downstream Connections in the Hypergraph menus.

View Attribute Connections by moving your cursor over the line that connects the nodes together. The 
complete object names and input and output attributes are listed at each end.

Delete Connections by LMB selecting the connecting line then press backspace (The line will turn yellow 
to signify it has been selected).

Connect nodes together by MMB dragging one node on top of another node. If a logical and obvious 
connection can be made then it will be made automatically, otherwise, the Connection Editor will be 
opened with the correct nodes already inside the Connection Editor ready allowing you to specify which 
attributes should be connected.

Hypershade / Visor
The Hypershade and Visor windows are used to build and manage textures and materials for establishing the rendered 
look of your scene. Although these are listed as separate UI elements they are most often used together and appear as 
a single UI component.
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Hypershade / Visor window

The Hypershade portion of the Hypershade/Visor shares similar functionality to the Hypergraph. In earlier 
versions of Maya the Hypergraph was used to create and manipulate shader networks. The Hypershade displays 
materials and textures much like the Hypergraph displays nodes and attribute connections. 

The Visor is the portion of the Hypershade/Visor combination where you will find your scene elements that you 
have in your scene or may want to bring into your scene to help create the look of objects when they are rendered. 
Lights, Cameras, Textures, Sourceimages, and Materials can be found in the Visor. You can also use the Visor 
to navigate around your hard drives to find other elements not associated with your current project.
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Using the Hypershade/Visor:

The Hypershade/Visor is found under Window → Hypershade... or Window → Visor...

The Hypershade area is a work area most commonly used for creating and editing shader networks.

Drag materials from the Visor to the Hypershade work area using MMB.

Clear the Hypershade work area by pressing the eraser icon.

Drag a material into the Hypershade work area then press the show up and downstream connections 
button to see the related nodes on the shader.

The Visor has two main areas; The Rendering area where you see the items already in your scene. The 
Create area where you can create items like materials, lights and textures to bring into your scene.

Navigate the view of the Hypershade and Visor windows with the same camera controls you use for the 
Hypergraph and modeling viewports.

Zoom: alt + LMB +RMB

Pan: alt + MMB

Frame selected: press f

Frame all: press a

Graph Editor

Graph Editor

The Graph Editor is where you manage the keyframe animation that you have created. The Graph Editor presents 
keyframe animation in terms of curves called animCurves. 
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Using the Graph Editor:

Open up a scene file from one of the other tutorials first so you have something to work with. File → 
Open Scene... and select jelly4.ma.

The Graph Editor is found under Window → Animation Editors → Graph Editor...

Select objects and attributes for animation editing from the left-hand side “Outliner” type list. The 
related animCurves will be displayed in the right-hand graph portion.

Press a or f to frame all or the selected animCurves in the Graph Editor. 

Select the animCurve with LMB and then select the keyframe knots on the curve to edit the tangency or 
position of the keyframe.

Press w to enable the translate manipulator (manip for short) then press MMB and drag to reposition 
or press r to enable the Scale manipulator.

You can snap to time or value by pressing the Time Snap button or the Value Snap button.

Buffer Curves allow you to see a ghosted image of where the curve was before you manipulated it. 
Enable Buffer Curves by View > Buffer Curves (In the Graph Editor menu).

You can snap your curve back to the original shape by Curves > Swap Buffer Curve. (In the Graph 
Editor menu)

The Stats section lets you see and edit the keyframe values manually.

Navigate the view of the window with the same camera controls you use for the Hypergraph:

Zoom: alt + LMB +RMB

Pan: alt + MMB

Frame selected: press f

Frame all: press a

Render Globals
General rendering settings are made in the Render Globals window. From the Render Globals window you can adjust 
settings for the rendered image size or resolution, Anti-aliasing quality, Raytracing quality, Motion blur, and IPR 
options among many others.
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Render Globals

Using the Render Globals:

Open the Render Globals from Window → Render Globals... 

Set image naming syntax and padding from the Image File Output section.

Set render size or resolution aspect from the Resolution section. Lock Device Aspect Ratio should be on 
for digital video work that requires “non-square” pixels. You can choose from the list of common 
standard formats or create a custom resolution and aspect ratio.

Anti -aliasing Quality settings control how smoothly curved surfaces are rendered as well as filtering 
quality of textures. There are presets available for varying degrees of quality or you can create your own 
custom settings. These settings will have a large impact on render times vs. quality.

Raytracing can be turned on and off from this section. If you are Raytracing you can also control what 
degree of Raytracing is performed. Reflections, refractions, and shadows can have separate sampling rates. 
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Field Options is where field rendering settings are made. Field dominance and scanline ordering can be set 
from this section.

Motion Blur is essential for realistic motion as our eyes and the camera see movement. Maya has 2 types 
of motion blur:

2D motion blur is done as a post process and, for many circumstances, will create very realistic motion 
blur effects. This is a much faster method of rendering motion blur. With the 2D blur being used you 
have options for setting the blur length and blur sharpness.

3D motion blur involves much more computation as object positions are calculated and used to 
establish the effect of blurring an object that is moving in 3 dimensions. If you have objects that are 
crossing in front of other moving objects or a complex movement of the camera you may want to use 
this method of motion blur.

Render Options section is where many special post processes are enabled and executed. Environment 
Fog is established from this section as well as Gamma Correction and other general settings.

IPR Options are set from this section. IPR is Maya’s Interactive Photorealistic Renderer. With IPR you 
can edit your lighting and material assignment and settings very quickly. This section controls which parts 
of IPR rendering takes place. Post process effects are toggled on and off.

Paint Effects Rendering Options section enables you to render the paint effects strokes separately from 
the other elements in the scene. Very useful for compositing.

Render View

Render View
The Render View window is where you test render your scene. The Render View window is also where you use IPR, 
Maya’s Interactive Photo-realistic Renderer. 

Using the Render View Window:

Open the Render View window from Window → Rendering Editors → Render View...
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Quickly establish a wire frame Snapshot of what you will be rendering by selecting Render → Snapshot 
→ Current (In the Render View menu).

To render a region LMB drag a box around the area you want to render then select Render → Render 
Region (In the Render View menu).

To render the full image as the perspective camera sees things select Render → Render → 
Current(persp).

To keep an image for comparison in the Render View window’s buffer select File → Keep Image in 
Render View (In the Render View menu) or press the Keep Image button.

To save the image to your hard drive select File → Save Image... (In the Render View menu).

To view separate components of the image select Display → Mask Plane or Red Plane for example.

To use IPR first you must create a deep raster image by selecting IPR → IPR Render → Current (persp) 
(In the Render View menu). Once the IPR image has been created you are prompted to select a region to 
update. LMB drag a box to select a region to IPR render. Now as you update your materials or light 
positions for example the region will update in a scrolling manner from bottom to top. Depending on your 
system configuration this update can happen very quickly and interactively.

Working in Maya’s Camera Viewport

Using the Camera
Viewing your scene in 3D is made very easy in Maya using the camera viewports. The hotkey and mouse interaction 
for camera manipulation in Maya is widely regarded as the best in the industry. 

Camera manipulation: By default a new scene in Maya will contain 4 cameras, a perspective camera and 3 
orthogonal cameras.

Perspective Camera: The perspective camera mimics the way a film or television camera operates and 
displays your scene. 

Orthogonal Camera: Top, Side, Front, orthogonal cameras are provided by default. These cameras 
display the scene without a vanishing line of sight or perspective view. They are used to accurately 
position objects in relation to world space and the grid that is used to measure distances.
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Camera Hotkeys: The cameras and views in Maya are positioned and oriented by depressing the alt key in 
conjunction with the LMB (Left Mouse Button) and MMB (Middle Mouse Button).

Orbit: alt + LMB

Zoom: alt + LMB + RMB

Pan: alt + MMB

Frame selected: press f

Frame all: press a

Display Hotkeys: The viewport has hotkeys that control display properties such as shaded and wireframe 
modes:

Press 1, 2, or 3 keys for lowest to highest resolution display smoothness on selected NURBS objects.

Press 4 key for wireframe display

Press 5 for shaded display no textures

Press 6 for shaded display with textures

Press 7 for shaded display with textures and lights

Viewport menus: The camera viewport has its own set of menus that further control viewport display 
properties and camera attributes.

View: Camera settings and bookmarking of camera views.

Shading: Various shading and display settings 

Lighting: Lighting display settings

Show: Filtering for object type display

Panels: Shortcut to Panel and Layout settings as well as camera selection and creation.

1 Start a new scene and create a primitive object
n File → New Scene

n Create a primitive object to view and move.

Create → NURBS Primitive → Torus

Press 1, 2, 3, 4, and 5 keys to see varying degrees of surfaces smoothness and shaded mode display.

2 View the primitive object with the perspective camera
In the Perspective viewport:

n Press f to frame this object
n Orbit the object by pressing and holding down the alt key while pressing and dragging the LMB.
n Pan the camera around using alt + MMB.
n Zoom in to the object using alt + LMB + MMB.

Translate | Rotate | Scale manips
Moving objects around your scene is made easy with Maya’s move tools. To activate the move tool manipulator:

Translate: Press w

Rotate: Press e

Scale: Press r

Quit Move Tool: Press q
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Special Tool manips: Press t

These keys make up the QWERTY keys on the keyboard. These keys have been chosen for these often used 
functions due to the comfortable and easy reach with which the left hand’s fingers can reach them.

3 Duplicate and translate a series of primitive objects
In the Perspective viewport:

n LMB drag to select the primitive object in your perspective view.
n Press Ctrl + d to duplicate your primitive object.
n Translate the new duplicated object up.

Press w to activate the Translate manip.

Select the green Y manip handle arrow.

LMB drag to move the object in the Y direction only.
n Rotate the primitive object.
n Scale the primitive object.
n Press Backspace to delete the duplicated torus.

4 Select the makeNurbsTorus node in channel box
Now you will select the node that controls a primitives construction history and manipulate these attributes with 
the shown manipulator tool associated with this object.

n Display the Channel Box if it is not displayed

Select Options → Channel Box to toggle the Channel Box
n Select the original NURBS torus that you created.

In the Channel Box the nurbsTorus1 transform node is displayed. Below is the nurbsTorusShape1 node 
and below that listed as an Input node is the makeNurbTorus1 node.

n In the Channel Box click on the makeNurbTorus1 node.
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5 Manipulate the nurbsTorus using the Show Manipulator Tool
n Press t to show the makeNurbTorus1 construction history manipulator tool.

Select the handles presented by the Show Manipulator Tool with your LMB. Drag these manips to get 
a feel for what each one does.

As you move the manipulators notice the values change in the Channel Box. These values can be 
keyframed and animated. (RMB in the attribute field and select key selected)

Selection Action vs. Tool based Commands
In Maya there are two methods of carrying out commands on objects. A command is a process that you perform or 
apply to one or more objects or nodes. Applying a deformation to an object is an example of this process.

6 Apply a Lattice Deformer to your primitive object
The Lattice Deformer is a very powerful deformer. A lattice is a cage shaped deforming tool that gets created 
around the selected object or objects. This lattice can be manipulated to deform the underlying object.

n Select your primitive object, in this example the nurbsTorus1 object.
n Select Deform → Create Lattice (from the Animation Menu set)

A Lattice deformer is created and applied to the selected object.

This is an example of a Selection/Action command. 

An object was selected and then an Action was applied to this object.
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7 Adjust the Deformation Membership
Once you have applied a deformer you can control which part of the affected object is obeying the deformation. 
This is called Editing the Membership.

n Select the Lattice Points

LMB drag over the lattice to select it in the viewport

Press RMB over the Lattice

A marking menu is displayed with viable choices for the selected object. In this case the Lattice Points 
marking menu is displayed. 

RMB gesture to select the Lattice Points marking menu

LMB drag a box around a collection of Lattice Points
n Press w to display the Translate manip

Translate the group of Lattice points to deform the primitive object.

Exit this component mode by pressing F8 twice
n Select Deform → Edit Membership Tool

Note the name on this command includes the word “Tool”. This signifies that when you select this menu 
item you will be placed into a tool that will prompt your actions in order. 

Note: To see these prompts make sure the Help Line is displayed.

Note the cursor changes to a special arrow shape

The Help Line prompts you with:

Edit Membership Tool: Select a Set or a Deformer

If the lattice is not selected.
n Select the Lattice in the viewport

The CVs of the torus are displayed and the Help Line prompts you with:

Edit Membership Tool: ffd1Set: Add with Shift+LMB. Remove with Ctrl+LMB.
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n Follow these directions and remove some of the CVs from the Lattice’s membership.

Note that the shape of deformation changes as these CVs are not participating in the deformation.
n Press q to quit the Edit Membership Tool

This is how a Tool based command in Maya will typically work. You enter a mode and you follow the directions 
in the Help Line. In multiple choice tools you may be prompted to press the Enter key to validate a certain step 
before moving to the next step of the tool.

CONCLUSION
This has been a brief exposure to the Maya user interface. The Maya on-line documentation is another place that you 
should investigate for answers to user interface questions and coverage of the other windows, editors and UI 
components omitted from this tutorial.

There are many options in Maya. These options are what make Maya a powerful and flexible application. As you get 
comfortable with one area of Maya you will also find yourself getting comfortable with other areas of Maya due to the 
continuity of usage and usability that is carried throughout the application.

Use the Help Line. By always displaying the Help Line and Pop Up Help you will have a prompt that explains what a 
button is and how to proceed in a tool based command. 
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