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Comic Book Setup - Part 1

This tutorial shows you how to set up a comic book type magazine for character 
animation. This Setup is the one used to create the target poses used in the Blended 
Comic Book tutorial.

In this tutorial:

�  Using the Wrap Deformer

�  Using Wire Deformers

�  Clustering Curve CVs as Animation Handles

�  Creating a Reset Pose Shelf Button

�  Strategies for Blend Shape Target Creation



Comic Book Setup Questions? visit www.aliaswavefront.com/tasteofmaya
Note: Before you start: This tutorial requires Maya scene files. If you haven’t installed the tutorial files go to the 
“Try Maya” section of the “Taste of Maya” CDROM to install.

Starting Maya: You can start Maya by double-clicking the Maya 2.5 Evaluation icon on the desktop or from 
Start → Programs → Maya 2.5 Evaluation → Maya.

In Maya: Once the tutorial files have been installed you will need to set the current project in order to access 
the Maya scene files. To set the current project from within Maya select File → Project → Set... and 
Navigate to the directory where you installed the Maya scene files. Select the directory: Maya_tutorial_data 
and press OK.

Character Control 
The animator’s job is to bring life to an object. When you animate you have clear ideas of how the object/
person/animal will move. To create this movement, your character must be manipulated into sequences of 
poses. 

Before you can animate your character, the character must be setup. This setup is much like creating a 
puppet that will be able to perform movements based on input from the animator. Maya provides a 
powerful suite of tools to do this type of work.

In this tutorial you will work with Maya’s deformer tools to create a control mechanism for the comic book. 
This setup will allow you to move the comic book into human-like poses.
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Scene file descriptions:

comicsetupstart.ma : This is the scene file you will start with. It contains a textured comic book object and some 
curves.

comicsetupdone.ma : This scene file contains the finished example of the comic book ready for animation or 
blend shape target creation.

Comic Book Cover Texture
The source image for the comic book cover texture is located in the sourceimages directory. You may have to re-
establish the path to this texture in the Hyper Shade Editor. This process is shown below. Source images for 
textures should be referenced automatically when the project structure is established. You may have to establish 
this path the first time you open a scene file however.

Wrap Deformer
The wrap deformer lets you use any object as a deforming object. Other deformers in Maya such as the lattice 
deformer work from a predefined shape such as a cube. The wrap deformer can be a NURBS or polygonal 
surface in any shape you need. In this tutorial you will work with a NURBS plane as a wrap deformer. Think of 
the wrap deformer as an object that will control the object/s it is connected to.
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When working with an object that is made up of more than one surface it is better to simplify this group of 
objects down to a single surface or deformable shape.

One way to do this is to create a Wrap deformer object.

1 Open comicBookStart.ma
� Select File → Open Scene ...

Select comicsetupstart.ma

� Press Open 

This file contains three objects under the group node comicBookGroup: comicBookObject, wrapPlane 
and wireCurves.

comicsetupstart.ma configuration and contents

comicBookObject is a group node that contains the NURBS surfaces that make up the comic book. This 
object started life as a NURBS cube.

The comicBook object has been texture mapped. Press the 5 key for shaded display, 6 key for texture 
shaded and the 7 key for textures with lighting in the perspective view.

The wrapPlane object is a NURBS plane that has been scaled to fit just around the comicBook.

Inside the comicBookGroup is another group named wireCurves. This group contains several curves 
that you will use as wire deformers for shaping the comicBook into various poses later in this tutorial.
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Comic Book Cover Texture

If the comic book frontCover texture does not appear on the magazine cover you will need to establish the path 
to this source image.

� In Hypershade/Visor double click the frontCover material from the Visor’s Materials folder.

frontCover material in the Attribute Editor
� Use the Attribute Editor to edit the material called frontCover. 

The frontCover material has a file texture connected to the Color attribute.
� Navigate to the file1 texture node by pressing on the righthand side arrow button for the Color 

attribute.

file1 texture attached to the frontCover Color attribute
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The Image Name attribute will need the absolute path to the comicBook.iff image located in the 
sourceimages directory. 

� Click on the folder icon then navigate to the sourceimages directory. 
� Select comicBook.iff and press Open.

2 Create a wrap deformer for the comicBook
To simplify the deformation applied to the multiple comic book surfaces you will apply a wrap 
deformer.

� Open the Outliner, Window → Outliner... If it is not already displayed.
� In the Outliner Ctrl LMB select the comicBookObject then the wrapPlane objects. Make sure to 

expand the comicBookGroup to get to the comicBookObject group in the Outliner.
� Select Deform → Create Wrap (the deform menu is found under the Animation menu sets).

This will create a wrap deformer between the wrapPlane and the comicBookObject group.

The order of your selection is important. You can tell which object is the wrap by seeing which object 
gets a base object added to it. In this case a new object called wrapPlaneBase is created indicating that 
the wrapPlane is the wrap deformer.

Tip: If you find that you have selected objects in the wrong order, simply press z to undo and reverse your 
selection order and try it again.

The comicBook group is now being controlled by the wrapPlane shape. To move or deform the 
comicBook objects you will move or deform the wrapPlane object. This single surface is a much simpler 
object to manipulate.

3 Test the wrap deformer
You should test the wrap deformer.

� Select the wrapPlane object in the Outliner.
� Press F8 to enter component mode. 

You should see the CVs of the wrapPlane displayed. If not check your component pickmask 
settings to ensure that the CVs are pickable.

Note: The pickmask is located on the status line and is also known as the selection mask. From this portion of the 
status line you can select which objects or components of objects are selectable and/or which are masked 
from selection. See the fundamentals tutorial for more information on this powerful feature of Maya.

� LMB drag select a CV on the wrapPlane object.
� Press w to display the transform manipulator
� Translate the CV and confirm that the comicBook object follows along. Press z to undo.

You could begin building targets by “tweaking” these CVs into a pose then duplicating the comicBook 
group to form a snapshot of this pose. But to make the process a little easier you are going to create a 
more generalized method of tweaking using wire deformers and clusters.

Wire Deformer
Another Maya deformer is the Wire Deformer. This deformer turns a NURBS curve into a object that will 
deform a surface much like a wire inside a piece of cloth.
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1 Create wire deformers between the wireCurves and the wrapPlane using the Wire Tool.
Selection order is not used for envoking this function. You will select the objects as you are prompted by the 
tool. This is the difference between Selection/Action and Tool methods of working in Maya.

� Select Deform → Wire Tool...

The bottom of the Maya window contains a line called the Help Line. You can toggle this section of the 
UI under the Options menu. The Help Line provides tips and usages for tools and selection operations. 
The Wire Tool will prompt you to select the object you want the curve to deform first.

� Select the wrapPlane in the Outliner

Press Enter to validate the selection.

Note that the Help Line prompts you to then select the curves
� Ctrl select the wire curves in the Outliner. These curves are located under the wireCurves group.

Press Enter to validate the selection

The curves will now deform the wrapPlane as you move them. To move the curves you will cluster the curve 
CVs. The clusters will, in a sense, move the curve CVs’ positioning up into worldspace. This will make it easier 
to control the curve CVs’ transformation and allow for keyframing of the curve CVs.

� Once you have created your wire curves you can hide or template the wrapPlane. Templating the 
wrapPlane will keep a wire version visible but not selectable. Hiding the wrapPlane will keep it out of 
view and only selectable in the Outliner.

� To see the objects and curves clearly, use wireframe mode by pressing the 4 key.
� In the Outliner select the wrapPlane and press Display → Object Components → Templates this will turn 

the wrapPlane object into a templated object, one that is visible but not selectable.

2 Cluster the CVs of the wire curves
A cluster is a grouping of curve or surface CVs (Control Vertices). A cluster is a very basic deformer. It is used 
for various jobs that entail moving curve or surface CVs. You will use them in this example as a method of 
controlling the wire deformer curve CVs.

� Select topWireCurve and press F8 to toggle to component mode.
� LMB drag select the two edgemost CVs on the topWireCurve curve. For example the two adjacent 

curve CVs in the upper righthand corner.

Select Deform → Create Cluster
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Pattern of Cluster assignments to wire curve CVs, note center clusters are clustering 3 CVs each.

Tip: When you create the cluster the selection of the curve will be cleared. You will need to select the curve in the 
Outliner again and press F8 twice to get back to component mode for CV selection. Use the “g” hotkey to 
repeat the last command once you have selected the next CVs to be clustered. In this case the Deform → 
Create Cluster command will be repeated on the selected CVs.

� Repeat this for the rest of the CVs on this curve using the above image as a guide. Use the “g” 
hotkey to “repeat last command”, to speed up your workflow.

� Repeat this for the other CVs on the mid and bottom curves in the following manner:

Edge CVs: The two edge CVs of each curve get a cluster

Center CVs: The center three CVs of each curve get a cluster

Mid curve CVs: The CV between the center and the edge gets a cluster. See the figure above 
but also experiment with different configurations.

Note: The curves provided for making the wire deformers have been tweaked or shaped into the curved pattern 
in order to better control the surface they are associated with. It is a subtle thing that provides a little more 
control over the wrapPlane surface.
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More about Clusters
Although the cluster is a deformer, you can also think of the cluster as moving the CV components up into world 
space. Using the cluster deformer in this manner you can think of it as a handle for components. A handle that 
can have keyframes applied to it and animated as any other object. 

You can apply a cluster to surface CVs as well as curve CVs. You can also adjust the weight of the deformation 
on a per CV basis. With surface clustered CVs you can use Artisan and it’s paint weights technology to adjust 
these weights.

A cluster can also behave according to to its parent. The Relative attribute on a cluster controls this behavior. 
This attribute when turned on lets you parent the cluster to another object without creating a double 
transformation. For this tutorial it will not be a factor but if you wanted to parent the clusters to the magazine so 
that they travelled along with the comic book you would need to set this attribute to on.

3 Test the Clustered CVs
The setup is complete for this character. The next task is to see if the character can get in the necessary poses.

� Make sure you are in object mode by pressing the F8 key.
� Adjust the pick mask to only allow selection of Cluster deformers.

Pick Mask 
� In the Pick Mask select All Objects Off.
� In the Pick Mask deformer button RMB pulldown select Clusters.

Now with only clusters as selectable objects you can quickly select the clusters and translate them to 
form your poses. This prevents you from accidentally selecting other objects like the curves or comic 
book surfaces.

4 Group the Clusters
To make the file a little easier to control you will group the clusters you just created.

� In the Outliner, shift select the clusters then select Edit → Group . This will create a group of the clusters.
� Rename this group as clustersGroup.

To get the clusters back to the default undeformed positions: 
� select the clustersGroup then select Modify → Reset Transformations 

This will reset the group and its children back to the position that they were created at or < 0, 0, 0 > 
translation in X, Y, and Z. Later you will create a shelf button that will do this quickly.
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Adjust settings to the wrap and wire for best results
Here are the settings for the attributes of the wrap and wire deformers. You should also experiment with 
these settings to see what the valid range of values is and how they affect the deformation.

� Place the comic book into a somewhat exagerated pose by translating some of the clusters to form 
bends and folds.

� Switch to the Channel Box from Options → Channel Box.

� Select the wrapPlane object.

Channel Box of wrapPlane object showing Dropoff, Wrap Samples and wire attributes

Wrap
When you create a wrap deformer the object that is the wrap gets two attributes added to it. You can see 
these attributes in the channel box when the wrapPlane is selected:

Dropoff: This attribute controls how the wrap influence diminishes over distance. Values between 4 and 
8 seems to work fairly well but you can also see what happens at a value of 20.
10  A Taste of Maya   January 2000, Alias|Wavefront, a division of Silicon Graphics Limited. All rights reserved. By using this tutorial, you have agreed
to the terms and conditions which can be found in the setup.exe file in the Install Tutorials folder of the Taste of Maya CD-ROM.



Comic Book SetupQuestions? visit www.aliaswavefront.com/tasteofmaya
Wrap Samples: This attribute controls how accurately the wrap is deforming the surface or surfaces. The 
higher the value the more accurate the deformation will follow but also more slowly as this increases the 
computational overhead. A value of 15 is fairly accurate without too much calculation. Higher sample values 
can slow down performance.

Wire
When you create a wire deformer using one or many curves a deformer object is created called a wire. 
Sometimes it may be hard to get at this node. You can usually find it as a related tab in the Attribute Editor 
when you select one of the curves that you are using as a wire deformer. You can also see it as an Output node 
in the Channel Box. This is the preferred method of accessing related nodes and attributes.

Dropoff Distance: Each curve in the wire deformer has an entry for dropoff distance. In this case you will see 
3 attributes [0], [1], [2]. A value of 6 in each of these seems to work pretty good but again, experiment with 
these settings.

Envelope: This attribute controls the amount of influence the wire will have on the surface. Typically this 
value is kept at 1 but if you needed to exagerate the influence or decrease the influence you can adjust it here.

Rotation: This attribute controls the amount of rotation that the surface will get normal to the curve. 
Experiment with this attribute, you may find that in certain poses it will help the surface follow the curve’s 
bend without twisting too much. Valid values are from 0 to 1.

Making a Cluster Reset Shelf Button
You can also make a shelf button that selects all of your Clusters and performs the Reset Transformation with 
one button click. A shelf button is a command or series of commands that have been recorded as a macro and are 
executed by selecting the associated icon that appears on a shelf. The following steps will take you through 
creating and using a shelf button to reset your comic book clusters to their default positions.

1 Create a shelf button for Reset Transformations
� Hold down the Shift, Ctrl and Alt keys at the same time that you select Modify → Reset 

Transformations from the main menu. 

Note: You cannot use the Hotbox representation of the main menus in this manner to create a shelf button.

This will create a shelf button for this command on the currently displayed shelf. 

2 Edit the Shelf Button Command
� Select Options → Customize UI → Shelves...

� from this menu select Shelf Contents tab and then the Reset Transformations button that you have 
created.

� Select the Edit Commands tab, this displays the MEL commands that are executed when you press the 
shelf button. 

You need to add the “selection of your clusters” part of the command.
� Open the Script Editor, either by pressing the button in the far bottom righthand corner of Maya or by 

Window → General Editors → Script Editor.

� In the Outliner select the clustersGroup group. The action is reflected in the Script Editor as:

select -r clustersGroup;

� LMB drag to select this entire line of text (including the semi colon “;” at the end of the line). 
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When it is highlighted MMB drag it to the Shelves editor above the Reset Transformation 
command also known as makeIdentity. (You may have to press the enter key before the 
makeIdentity command to make room for the select -r... command to go above.) 

� Here is what the two commands in the shelf button editor will look like:

select -r clustersGroup;

makeIdentity;

� Now add a selection clear command. Under the makeIdentity line add:

select -cl;

Note that if you LMB drag select nothing in the perspecive view this is the command that is 
echoed to the Script Editor.

� You should now have three lines:

select -r clustersGroup;

makeIdentity;

select -cl;

� Once you have the command looking right then press the enter key on the “numeric” keypad to 
validate. Press Save All Shelves to save the shelves to the Maya preferences. 

Test the operation by translating some clusters and then press this shelf button to make sure it is 
working as intended.

You can build and edit shelf buttons in this manner to create handy “macros” for often repeated 
commands and series of commands.

Finished Scene File comicsetupdone.ma
The scene file comicsetupdone.ma is also provided as a finished version of the setup steps you have just 
completed. For the following steps and in the future, to work from a finished setup use this scene file.

Building Blendshape Targets
You now have a character that is setup and ready to animate. You can simply begin moving the clusters 
and keyframing their position. In this manner you can animate the comic book into many actions and 
performances. 

You can also record these poses as blend shapes targets. In the Blended Comic Book tutorial you see the 
results of creating these targets as a library of movement or as an in-between sequence.

The process of building blendshape animation involves creating blendshape targets that the base object will 
deform into. Typically, duplicates of the base object that form the candidate targets will have identical 
topology. This is desireable and will make the deformations smoother but also note that Maya will do 
blendshapes between objects that do not have identical topology or a one to one correlation between each 
objects geometric configuration, i.e. Vertice count, vertice position etc...

The following steps show you the beginning of the process.

1 Duplicate the comicBookObject as the base object.
You will need a comicBook to act as the base object. This comicBook will be the one that is animated 
with blendshape animation.

� Reset the clusters back to their default or un-deforming position. 
12  A Taste of Maya   January 2000, Alias|Wavefront, a division of Silicon Graphics Limited. All rights reserved. By using this tutorial, you have agreed
to the terms and conditions which can be found in the setup.exe file in the Install Tutorials folder of the Taste of Maya CD-ROM.



Comic Book SetupQuestions? visit www.aliaswavefront.com/tasteofmaya
� Select the comicBookObject group and press Ctrl d or select Edit → Duplicate to make a copy of the 
comicBookObject in its rest pose.

� Rename this group as comicBookBase

2 Pose the comicBookObject using the clusters
Now pose the character into poses that you can blend between. Think in terms of moving only a localized area 
like the hand to form a pose, the waist, the head, the foot. You will be adding these poses together so avoid 
having two poses that both move the same part of the character. This would result in double or summed 
movement and may not work the way you intended. This is the process for building Individual targets.

� Create a pose and then duplicate the comicBookObject group and translate this copy to a place behind 
your work area. Rename this group to something meaningful.

� Reset the clusters back to their default position.
� Pose the comic book again and duplicate the comicBookObject group again.
� Repeat this process until you have several target posed groups.

Two strategies for working with blend shapes
Blend shape targets can be used individually or as in-betweens.

�  Individual targets

The first strategy is to create individual movements that can be added together to form poses. For example you 
could create a target that just has the arm move and another target that has the leg move. When you create a 
blend shape using the default settings, a slider is created for each target. By combining these two targets you can 
put the character into the needed pose. This technique allows for reuse of targets to create many different poses.

�  In-Between targets

With this strategy you create a series of poses that complete a motion. When you create the blend shape you 
specify “In-Between” in the Create Blend Shape Option Box. This will create a single slider that transitions 
through each target.

Workflows for target creation:

Individual
1. Create a pose and then duplicate the comicBookObject group and translate this copy to a place behind your 
work area. Rename this group to something meaningful about the part of the object you are deforming,( ie. 
headBending).

2. Reset the clusters back to their default position.

3. Pose the comic book again and duplicate the comicBookObject group again.

4. Repeat this process until you have several target posed groups that will lead into one another and not 
overlap too much.

In-Between
1. Create a pose then duplicate the comicBookObject group, translate this copy to a place behind your work 
area. Rename this group to a numbered pose to identify the sequence order.

2. Translate the clusters to the next pose in the sequence.

3. Duplicate the comicBookObject group, translate and rename this group to the next numbered sequence.

4. Repeat until the poses have been created to complete the performance.
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CONCLUSION
There are many ways to animate a character in Maya. Each of Maya’s deformers has its strengths and 
because you can layer these deformers you have several options for getting the shape to go where you 
want it to go. 

Create simple control handles that quickly let you put the character where you want it. If you find that you 
need more control then add it in. But it is usually best to keep things simple at first.

Learn each deformer’s attributes and what they control. Work on very simple mockups first. Then apply 
what you have learned to the full model.

Work with the blend shapes created from this setup:
The Blended Comic Book tutorial available on the Discover Maya CD uses targets created by this setup 
technique in blend shape animation. The comic book serves a tennis ball takes a bow and even morphs into 
an anvil in this tutorial.
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Blended Comic Book - Part 2

This tutorial shows you how to use Maya’s blend shape deformer tools to animate a 
comic book. 

In this tutorial:

�  Creating individual and in-between blend shape animation

�  Keyframing blend shape animation

�  Deleting and Editing blend shapes

�  Strategies for creating blend shape targets
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Note: Before you start: This tutorial requires Maya scene files. If you haven’t installed the tutorial files go to the “Try 
Maya” section of the “Taste of Maya” CDROM to install.

Starting Maya: You can start Maya by double-clicking the Maya 2.5 Evaluation icon on the desktop or from Start 
→ Programs → Maya 2.5 Evaluation → Maya.

In Maya: Once the tutorial files have been installed you will need to set the current project in order to access the 
Maya scene files. To set the current project from within Maya select File → Project → Set... and Navigate to the 
directory where you installed the Maya scene files. Select the directory: Maya_tutorial_data and press OK.

Comic Book / Magazine animation
Applying animal characteristics to a normally in-animate object is a time honored and much demanded 
animation job. Advertisers often ask for their products to become actors in commercial and print pieces. 

In this tutorial you will create two types of blend shape animation using provided target poses. You will then 
animate between these poses.

A second tutorial called Comic Book Setup has been created that explores the techniques used for setting up the 
magazine for character control. This is the character setup that was used to create the character based blend 
shape targets you will be working with in the following tutorial.

Scene file descriptions:

comicbookstart.ma : This is the scene file you will start with. It contains groups of posed objects you will use 
to blend between.

comicbookanim.ma : This scene file contains blend shape animation using all of the provided target poses.

comicbookserve.ma, comicbookbow.ma, comicbookothers.ma : These scene files contain the comic book with 
various blend shapes applied matching the progression of this tutorial.

Layers:
The duplicated posed targets of the comic book in these Maya scene files have been organized into layers. 
These layers can be made visible by accessing the layer bar, Options → Layer Bar. To toggle the visibility of 
each layer press the RMB (Right Mouse Button) on the layer button, and select Visible.

Comic Book Cover Texture:

The source image for the comic book cover texture is located in the sourceimages directory. You may have to 
re-establish the path to this texture in the Hyper Shade Editor. This process is shown below.

Blendshape Animation
Blend shape animation in Maya is the technique of deforming a “base” object by blending through a series of 
“target” objects. These “target” objects are deformed into the poses that the “base” object will assume or morph 
into. The blendshape is then keyframed at the desired pose at the desired time.
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Blend Shape Editor Window 

Blend shape workflow in brief:
1. Create the object that will undergo blend shape animation (In this example it will be a comic book). 

2. Make multiple copies of the object (comic book) and deform them into poses. The posed copies are called 
targets. The original object that is undeformed but is going to have the blendshape applied to it is called the 
base. 

3. Apply the Blend Shape deformer to the targets and base objects.

4. Open the Blend Shape Editor, Window → Animation Editors → Blend Shape... adjust and keyframe the mix of 
blend shape target sliders.

5. Adjust keyframes and animation curves in the Graph Editor for smooth motion and blending.

Local and World Blend Shapes:
Blend shapes can blend between objects and only use the local space or component shape deviation or they 
can also include the world space transformations in each target. In this tutorial we will use the local space 
blend shape interpolation for blending between target poses.
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comicbookstart.ma objects and layers

Creating Blend Shape Deformer Animation
In the following tutorial steps you will be working with the blend shape deformer to create blend shape 
animation using provided target objects.

1 Open comicBookStart.ma scene file
� Start Maya
� Select File → Open Scene ...

Navigate to the location on your hard drive where you have copied the project files from the CDROM. 
The scenes directory is where you will find maya scene files.

� Select comicbookstart.ma

� Press Open 

This file contains several objects and groups of objects:

comicBookBase

bowPoses

servePoses
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heartBeatPoses

otherPoses

Open the Outliner to view these object groups as well as lighting and camera objects.

These objects are actually groups of objects. In the Outliner you can LMB on the + sign to the left of the object 
name to open the nested objects. These objects may be parents of other objects as well.

The comicBook object has been texture mapped. Press the 5 key for shaded display, 6 key for texture shaded 
and the 7 key for textures with lighting in the perspective view.

Comic Book Cover Texture
If the comic book frontCover texture does not appear on the magazine cover you will need to establish the path 
to this source image. When you have your project directory setup correctly, sourceimages like this one should be 
referenced automatically. You may need to establish this path when using these scene files with the evaluation 
copy of Maya for the first time.

� In the Hypershade/Visor window select the frontCover material from the Visor’s Materials folder.

frontCover material in the Attribute Editor
� Use the Attribute Editor to edit the material called frontCover. 

The frontCover material has a file texture connected to the Color attribute.
� Navigate to the file1 texture node by pressing on the righthand side arrow button for the Color 

attribute.
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file1 texture attached to the frontCover Color attribute

The Image Name attribute will need the absolute path to the comicBook.iff image located in the 
sourceimages directory. 

� Click on the folder icon then navigate to the sourceimages directory. 
� Select comicBook.iff and press Open.

You should see the comic book cover texture appear when you are in shaded texture mode. (Press 6)

Blend Shape Targets for Serve Poses
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2 Create a blend shape between the serve targets and the comicBookBase objects.
Create a blend shape relationship between the bow targets and the comicBookBase objects. Selection order is 
important.

� In the Layer Bar RMB toggle Visibiltiy for the ServePoses layer to see these objects in the viewport.

If the Layer Bar is not visible select Options → Layer Bar from the main menu.
� In the Outliner open the servePoses group to see its contents. There are several groups each listed in 

order servePose1, servePose2, etc.... These groups will be the targets for the blend shape.
� Select these target groups in the Outliner by holding down the Ctrl key and LMB selecting each one or 

Shift select the top group in the list then the bottom group in the list to select these groups/objects 
quickly and in order. 

� With the Ctrl key pressed select the comicBookBase group to add this to the selected objects list last.

This order of selection is important. The targets first and the base object last. The order of target selection will 
also determine the order of target slider or target position in the blend shape.

� In the Main Menu select Animation as the menu set. (Left hand upper corner)
� Select Deform → Create Blend Shape ❐ option box. Confirm that Blend Shape is reset to the default 

values by pressing Reset. The default settings will make “Individual” targeted sliders. But we want to 
do an “In-Between” blend shape first. Later we will do an “individual” blend shape.

Select “In-Between” check box so that it is checked.

Press Create to create the blend shape.
� Open the blend shape editor

Select Window → Animation Editors → Blend Shape ...

A blend shape slider should be created in this window. Adjust the slider through its range to see the 
base object morph between the series of target poses.

Blend Shape for Serve In-Between Poses

3 Keyframe the blend shape sliders to animate through the poses
By adjusting the slider and keyframing its value you can control the speed in which poses and blends between 
poses occur. 
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To change time LMB drag in the Time Slider time line. The current time field will reflect the current 
frame. 

Once a pose has been reached at the proper time, keyframe the slider by pressing the Key button in the blend 
shape window.

� Adjust the current time in the time slider. Key the poses for the desired time until you have a rough 
animation sequence.

If you just want a linear progression through the pose set a keyframe at frame 1 with a slider value 
of 0, change current time to frame 90 and set the slider to a value of 1 and press key. 

You may have to adjust the Range Slider, expanding the playback range to 1 - 90 frames.
� Press the play button to see the progression through the poses over time.

Deleting Target Shapes
If you are happy with the blend shapes being derived from the targets you can delete the targets and still 
retain the blend shape animation. The deformation information is retained in the blend shape when you delete 
blend shape targets. This can reduce the size of your Maya file. To get the deleted target back, you could set 
the base object in the pose with the blend shape slider then duplicate the base object.

Note: To edit the blend shape you will use the same type of selection/action. For example to delete a blend shape slider 
you would select the target that corresponds to the slider then the base object and then select Deform → Edit 
Blend Shape → Add/Remove/Swap to edit the blend shape in the manner necessary.

Two strategies for working with blend shapes
Blend shape targets can be used as In-Betweens or as individual targets.

�  In-Between targets

With this strategy you create a series of poses that complete a motion. When you create the blend shape you 
specify “In-Between” in the Create Blend Shape Option Box. This will create a single slider that transitions 
through each target. This is what you just did to make the comic book serve the ball.

�  Individual targets

This strategy involves creating individual movements that can be combined together to form poses. For 
example you could create a target that just has the arm moved or posed and another target that has the leg 
moved or posed. When you create a blend shape using the default or individual settings, a slider is created for 
each target. By combining these two targets you can put the character into the needed poses. This technique 
allows for reuse of targets to create many different poses by combining them. You need to be careful in 
selecting how you transform between some poses. They may not be compatible without using some sort of 
transition pose.

1 Change the Time Slider range
If you have created animation and would like the following blendshape animation to occur after the keys you 
have created then adjust the range slider farther down the timeline

� If your first blendshape animation runs from frames 1 to 90 then set the range slider to run from 90 to 
180. You can do this in the Playback Start Time and Playback End Time fields of the Range Slider. 

You may have to increase the End Time field to a value greater then your Playback End Time, in this 
case greater than 180.
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2 Create “Individual” blend shapes using the bow poses
Now you will create a blend shape that uses individual target poses. You will animate the base object by 
blending in a combination of target poses.

� On the Layer Bar toggle visibility for the ServePoses to hidden the BowPoses to Visible.
� In the Outliner open the bowPoses group
� Shift Select from top to bottom the bowPose groups: headPose, rt_shoulderPose, rt_armPose, etc....
� Ctrl select the comicBookBase object last.
� Targets and base should be all selected at this point.

Select Deform → Create Blend Shape ❐ to open the option box.
� Press Reset to reset the options to the default settings. Note that In-Between is not checked.

Press Create

Blend Shape for Comic Book Bow below the serve Blend Shape.

The default settings for blend shape will create blend shape sliders for each individual target you have 
selected. Each of these sliders will contribute to the shape of the base object.

If the comicBookBase object looks a little chunky texture-wise press 3 to increase the display smoothness.

3 Animate the Blend Shape
Adjust and key the individual slider values to form poses that will create animation on the comic book. The 
targets that have been provided are designed to work for the character to take a bow.

� Open the blend shape window to view the individual blend shape sliders.

Select Window → Animation Editors → Blend Shape ...
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Adjust each slider to see how they work together.
� In the same manner as the earlier steps, key the slider value against different frames. 

Tip: Another handy feature of the Blend Shape editor is the KeyAll button. This lets you apply a key on all the sliders at 
once at the current frame. 

You can work in a rough manner and clean up the animation in the graph editor. Note that some targets may 
not flow smoothly into each other and also that some poses will add to each other and require mid-range 
values to compensate.You may find that you cannot get to a pose without the need for some additional in-
between target poses.

The second tutorial that is related to this example explains how to setup the comic book as a character for 
quickly creating these target poses. 

4 Create Blend Shapes using the other provided target objects
The scene file also contains two more groups of targets, hearBeatPoses and otherPoses. 

� In the Outliner open the heartBeatPoses groups and the otherPoses groups.

To view these targets in the viewport toggle on their respective Layers.
� Shift Select from top to bottom the heartBeatPoses groups.
� Ctrl select the comicBookBase object last.
� Targets and base should be all selected at this point.

Select Deform → Create Blend Shape ❐ to open the option box.
� Press Reset to reset the options to the default settings. Note that In-Between is not checked.
� Select In-Between so that it is checked.

Press Create
� Repeat this process for the otherPoses group but do not use In-Between. 

You should have 4 blendshapes in your scene and the ability to blend the comicBook into many different 
poses and shapes.
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Heart Blend Shape Applied to the Comic Book

Workflows for target creation:

Individual
1. Create a pose and then duplicate the comicBookObject group and translate this copy to a place behind your 
work area. Rename this group to something meaningful about the part of the object you are deforming,( ie. 
headBending).

2. Reset the clusters back to their default position.

3. Pose the comic book again and duplicate the comicBookObject group again.

4. Repeat this process until you have several target posed groups that will lead into one another and not 
overlap too much.

In-Between
1. Create a pose then duplicate the comicBookObject group, translate this copy to a place behind your work 
area. Rename this group to a numbered pose to identify the sequence order.

2. Translate the clusters to the next pose in the sequence.

3. Duplicate the comicBookObject group, translate and rename this group to the next numbered sequence.

4. Repeat until the poses have been created to complete the performance.
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CONCLUSION
The power of Maya’s blend shapes comes from quickly creating morphing and blending between objects of like 
or disimilar shapes. There are many ways to animate a character in Maya. Each of Maya’s deformers has its 
strengths and because you can layer these deformers you have several options for getting the shape to go where 
you want it to go.

Blend shape animation can be broken down into two basic techniques:

1. Each portion of the shape is blended individually, this is a common technique for blending facial animation. 
A blend for each facial muscle.

2. The entire shape is blended into complete poses, happy face, sad face, mouth phonems, and other 
expression based shapes.

Learn How the Target Poses used in this tutorial were created:
The Comic Book Setup tutorial further illustrates Maya’s powerful deformer tools. Layering deformers to create a 
structure that is easy to control is the goal of this tutorial. The target poses used in the bow and serve blend shape 
were created using the character setup you will learn in the Comic Book Setup tutorial.
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