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Character Setup

This tutorial goes through the steps to add animation controls to a previously modeled character. 
The character in the scene below is wearing clothes made with Cloth and the scenery has been 
created with Paint Effects.

The following topics are discussed:

n  Creating skeletons,

n  Using Smooth Skin to bind a model to a skeleton,

n  Adding IK chains for efficient character control, and

n  Combining custom attributes and Set Driven Key to automate character controls.

An animated character



Character Setup Questions? visit www.aliaswavefront.com/tasteofmaya
Note: Before you start: This tutorial requires Maya scene files. If you haven’t installed the tutorial files go to the “Try 
Maya” section of the “Taste of Maya” CDROM to install.

Starting Maya: You can start Maya by double-clicking the Maya 2.5 Evaluation icon on the desktop or from Start 
→ Programs → Maya 2.5 Evaluation → Maya.

In Maya: Once the tutorial files have been installed you will need to set the current project in order to access the Maya 
scene files. To set the current project from within Maya select File → Project → Set... and Navigate to the directory 
where you installed the Maya scene files. Select the directory: Maya_tutorial_data and press OK.

BUILD A SKELETON
1 Open the file characterModel1.ma

2 Press F2 to change the menu set to animation

3 In the side view build leg joints with Skeleton → Joint Tool as shown below
n start at the hip and place a joint at the knee, ankle, heel, ball and toe of the leg. There should be five joints 

in total.
n When you have placed all five joints press enter to complete the leg.

Tip: Hold the x key when placing joints to snap to the grid.

Joints placed for the right leg

Start joint

knee joint

ankle jointball joint

heel jointend joint
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Note: To see your Maya display as pictured, press 6 to transfer to textured mode and Shading → Shade Options → X-
Ray.

4 In the front view move the leg over so that it matches the geometry of the right leg
n Press w to use the move tool.
n Click on the right arrow of the manipulator to constrain the movement to the x-axis.
n Use the MMB to move the leg to fit in the geometry
n If you want to change the joint display size select Display → Joint Size and choose a different size

5 In the side view build the back with Skeleton → Joint Tool as shown below
n Place the first joint slightly above the hip joint. There should be eight joints in total.
n Press enter to complete the back skeleton

Joints placed for the back

6 In the top view build the right arm joints with Skeleton → Joint Tool as shown below
n The arm is made up of five joints starting at the clavicle.
n Press enter to complete the skeleton.

Start joint

End joint
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Joints placed for the right arm

7 Move the skeleton chain up to fit in the arm
n Use the move tool and constrain the movement to the y-axis using the manipulators.

8 Select the shoulder joint and rotate and scale it so that the bones are oriented correctly with the 
arm

Adjusting the arm bones to match the arm geometry

9 Select the right clavicle joint and shift select the joint at the base of the neck and Edit → Parent
n The clavicle is the joint above the shoulder, closest to the spine.

End joint

Start joint (clavicle)

shoulder joint
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n To select a joint you can click LMB directly on the joint or you can click LMB drag across the bone below 
it. For example to select the elbow joint you would click LMB drag across the forearm bone

10 Create the left arm
n Select the right clavicle.
n Choose Skeleton → Mirror Joint p to open up the options dialogue box.
n Set the following options:

Mirror Across: YZ
n Press Mirror to create the left arm.

Mirroring the arm

11 Parent the right leg to the back skeleton by selecting the right hip joint followed by the joint at 
the base of the back and Edit → Parent

12 Create the left leg by selecting the right hip and Skeleton → Mirror Joint

SKIN THE CHARACTER
1 Open the file characterModel2.ma or continue from the last step

2 Skin the body of the character first
n Select the body of the character 

Do not select the feet surfaces at this step. They will be bound to the skeleton in a later step.
n Shift-select the root joint of the skeleton

The root joint is the joint at the base of the back that all of the other joints branch off from. When it is 
selected and you move it all the other joints in the hierarchy will move as well.

n Select Skin → Bind Skin → Smooth Bind.

3 Test the bind by rotating joints in the skeleton

Tip: Use the z key to undo any joint rotations so the character is in the previous pose or use Skin → Go to BInd Pose.
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4 Skin the feet next
n Select the joints of the right leg from the knee to the toe. 

Start by selecting the toe joint and then shift selecting the ball joint, heel joint, ankle joint and then knee 
joint.

Tip: This selection may be done easily in the Hypergraph or the Outliner.

n Shift-select the right foot geometry

5 Skin → Bind Skin → Smooth Bind p, and set the following options:
Bind to: Selected Joints

Note: Because the feet are so big, this will keep them from getting skinned to joints that they shouldn’t be associated with.

Binding the shoe to the skeleton

6 Repeat steps 4 and 5 for the left foot

ADD IK TO THE ARMS AND LEGS
1 Open the file characterModel3.ma or continue from the last step

2 Activate the IK Handle tool with Skeleton → IK Handle Tool p, and set the following options:
n Current Solver: ikRPsolver

IK Handles give you control over the motion of several joints at once. IK Handles allow you to move one 
object (the IK Handle) and have several other objects (joints) change position by rotating. This allows you 
to animate a skeleton quickly as you only need to control one or two IK handles to get create lots of 
motion.

3 Click on the right hip joint followed by the right ankle joint to add an IK chain to the right leg. 
Press the y key to repeat for the left leg.

Pressing the y key puts Maya back into the tool that was used last. In this case pressing y is the same as 
selecting Skeleton → IK Handle Tool
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4 Repeat for the arms by pressing the y key and clicking on a shoulder followed by the 
corresponding wrist. 

IK chain added to the arms and legs

Tip: It is a good idea to rename the IK handles to keep the scene organized. Select an IK handle and rename it by clicking 
on the name at the top of the channel box.

5 You may test the IK chains by selecting an IK handle and moving it 

Note: Undo any transformations with the z key after you are finished testing.

ADD IK SPLINE TO THE BACK
1 Open the file characterModel4.ma or continue from the last step
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2 Select the right eye followed by the joint at the top of the head and Edit → Parent

Parenting the eye to the skeleton

3 Select the left eye followed by the joint at the top of the head and Edit → Parent

4 Activate the IK Spline Handle tool with Skeleton → IK Spline Handle Tool, and click on the 
stomach joint followed by the joint at the base of the neck

Adding IK Spline to the back

Note: You may test the IK Spline by selecting the IK handle and changing the value of the Twist attribute.
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Testing the IK Spline

Note: The IK Spline is controlled by a curve. When you create the IK Spline, the curve will be parented to the skeleton. If 
you select the curve and press F8 to change to component mode, you can move the CVs of the curve to control the 
back further. Remember to press F8 when finished testing to return to object mode.

ADD CONTROL FOR THE HEAD
1 Open the file characterModel5.ma or continue from the last step

2 Select the root joint and Display → Object Components → Selection Handles

Selection handle added to the root joint
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Note: Selection Handles have the highest priority for selecting geometry. This means it will always be easy to select the root 
joint.

3 With the root joint selected, Modify → Add Attribute...

4 Enter an attribute name of headTurn and press OK

Note: An extra attribute has now been added to the root joint. You should see it in the channel box.

5 Open the Set Driven Key window with Animate → Set Driven Key → Set p
Set Driven Key is a type of key available in Maya that allows you to connect an attribute from one object 
to an attribute of another object. For example you could have a sphere and a cone. The sphere’s translate Y 
could drive the scale Y of the cone. When you move the sphere in a defined range of values in the Y axis 
the scale Y of the cone would change accordingly. To use the Set Driven Key window you need to have a 
driver and a driven object to load. Once they are loaded you modify attributes on both the driver and driven 
and key them with the key button in the Set Driven Key window.

6 With the root joint still selected, press Load Driver

7 Select the joint at the base of the neck followed by the joint at the base of the head and press 
Load Driven

8 Set initial key for Set Driven Key
n In the Set Driven Key window, highlight headTurn for the driver. 
n Click drag on the two driven joints and then on rotateX and press Key

The Set Driven Key window

base of neck

base of head
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9 In the Set Driven Key window click on the Driver joint to activate it in the Channel Box and set 
Head Turn to 10

If you click on the name of an object listed in the Set Driven Key window (either the driver or driven), it 
will become the selected object and it’s attributes will show up in the Channel Box

10 In the Set Driven Key window click drag on the two driven joints to activate them and rotate them 
about 30 degrees in X

You can use the rotate tool and constrain the rotation to the x-axis using the rotate manipulator or you can 
type the value into the Channel Box.

11 Press the Key button in the Set Driven Key Window

12 In the Set Driven Key window click on the Driver joint to activate it in the Channel Box and set 
the Head Turn attribute to -10

13 In the Set Driven Key window click drag on the two Driven joints to activate them and rotate 
them about -30 degrees in X

14 Press the Key button in the Set Driven Key Window
Now that this setup is complete when you change the value of the headTurn attribute on the root joint it will cause the 
rotateX to change on the other two joints. If you select the root joint of the character and go to the Channel Box you 
can click on the Head Turn attribute. Once the Head Turn attribute is highlighted (not the number but the actual 
words), you can use your MMB in the perspective view and click drag left or right to change the values interactively.

Twisting the neck with Set Driven Key and a custom attribute

Note: You may test the setup by adjusting the Head Turn value between -10 and 10. To stop the arms from moving you may 
keyframe the IK handles with s or turn Stickiness ON in the Attribute Editor under IK Handle Attributes.
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ANIMATING THE CHARACTER
The final version of this file is called characterModel6.ma. If you want to try animating the character open this file. 
The main difference in this file is that the foot has been setup more completely for walking. Selection handles have 
been added to each of the IK handles for easier selecting.

The character ready for animating

The feet nodes have an added attribute called roll. If you adjust this attribute the foot will roll from heel to toe making 
for a nice walking motion. This foot setup comes from the Character Animation in Maya class.

The foot set to roll when walking
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Roll attribute added to left_foot node displayed in channel box
n Select one of the foot selection handles

In the Channel box you will see the selected object. Notice that there is an extra attribute on the foot called 
Roll.

n Click on the word Roll to highlight it. It should appear black as in the above image.
n Move your mouse over to the perspective view or one of the othographic views.
n Press the MMB and drag your mouse left or right. When you press the MMB a new mouse icon should 

appear that looks like arrows pointing left and right.

The following points should help you to animate the character:

Selection handles
n  Only the following six nodes need to be animated: root, back, right_wrist, left_wrist, right_foot and left_foot.

n  Keyframes can be set with s or with Animate → Set Key

right_foot left_foot

back
left_wrist

right_wrist

root
A Taste of Maya 13  January 2000, Alias|Wavefront, a division of Silicon Graphics Limited. All rights reserved. By using this tutorial, you have agreed to the terms
and conditions which can be found in the setup.exe file in the Install Tutorials folder of the Taste of Maya CD-ROM.



Character Setup Questions? visit www.aliaswavefront.com/tasteofmaya
n  Animation curves can be adjusted with Window → Animation Editors → Graph Editor...

n  When setting keys, start with the root and feet nodes to block out the animation

n  The finer animation of the arms, back and feet rolling should be secondary

n  You can get a real-time playback with Window → Playblast

Note: There are other animation workflows covered in the Comic Book and Jellyfish tutorials.

CONCLUSION
You have now experienced how easy it is to prepare a character for animation in Maya. This includes the following 
topics:

n  Creating joints and building skeletons,

n  Adding an IK chain to control arms and legs,

n  Using the IK Spline to the back for smooth and organic control,

n  Making custom attributes for finer control,

n  Set Driven Key to create relationships between nodes to simplify character control, and

n  Some basic animation concepts in Maya.

Character setup and animation can be very complex topics to cover. Alias|Wavefront offers a Character Animation 
course that explores these topics in depth. For more information go to www.aliaswavefront.com (Express Link to 
Training).
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